CVE-2024-25004

CVSS 3.1 Score 7.8 of 10 (high)

Details

Published Feb 9, 2024
Updated: Feb 14, 2024
CWE ID 787

Summary

CVE-2024-25004 is a vulnerability found in KiTTY versions 0.76.1.13 and earlier. It is categorized as a stack-based buffer overflow vulnerability that occurs due to insufficient bounds checking and input sanitization. This vulnerability allows an attacker to overwrite adjacent memory, leading to arbitrary code execution. The affected products include various versions of KiTTY. The potential danger it poses to organizations is high, with a base severity rating of HIGH and a base score of 7.8 out of 10. To remediate this vulnerability, it is recommended to update KiTTY to a version beyond 0.76.1.13 and apply any available patches or fixes provided by the vendor.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-25004 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options