CVE-2024-24817

CVSS 3.1 Score 4.3 of 10 (medium)

Details

Published Feb 22, 2024
CWE ID 200

Summary

CVE-2024-24817 is a vulnerability found in the Discourse Calendar plugin, an open-source discussion platform. In versions prior to 0.4, event invitees created in private categories or private messages can be accessed by anyone, even if they are not logged in. To remediate this issue, users should update the plugin to version 0.4, which resolves the problem. It is important to note that while putting the site behind a login requirement can disallow anonymous users from accessing this endpoint, logged-in users can still view the list of invitees in private topics. This vulnerability has a base severity rating of MEDIUM and a risk score of 5 out of 10, indicating a moderate potential danger to an organization's confidentiality.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-24817 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options