CVE-2024-24816

CVSS 3.1 Score 6.1 of 10 (medium)

Details

Published Feb 7, 2024
Updated: Feb 15, 2024
CWE ID 79

Summary

CVE-2024-24816 is a cross-site scripting vulnerability found in CKEditor4 versions prior to 4.24.0-lts. This vulnerability affects all integrators using samples with the misconfigured preview feature in production code. It allows attackers to execute JavaScript code, posing a potential danger to organizations using CKEditor 4 at version < 4.24.0-lts with affected samples in a production environment. The vulnerability can be remediated by updating to version 4.24.0-lts, which includes a fix for the issue. The severity of this vulnerability is rated as MEDIUM, with a base score of 6.1 according to NVD@NIST.gov.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-24816 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options