CVSS 3.1 Score 6.1 of 10 (medium)


Published Feb 7, 2024
Updated: Mar 6, 2024


CVE-2024-24815 is a cross-site scripting vulnerability found in the HTML parsing module of CKEditor4 prior to version 4.24.0-lts. This vulnerability affects all instances of the editor that have enabled full-page editing mode or enabled CDATA elements in the Advanced Content Filtering configuration. It allows attackers to inject malformed HTML content, bypassing the Advanced Content Filtering mechanism, and potentially execute JavaScript code. A fix for this vulnerability is available in version 4.24.0-lts of CKEditor4. The vulnerability has a base severity rating of MEDIUM and requires user interaction, but does not require any privileges or exploit complex attack vectors. It has a low impact on integrity and confidentiality, and no impact on availability. The exploitability score is 2.8 out of 10, indicating a medium level of exploitability.

Prevent cyber attacks with Recorded Future by prioritizing and patching critical vulnerabilities being exploited by threat actors targeting your industry. Book your demo to learn more.


Prioritize, Pinpoint, and Act to Prevent Vulnerability Exploits with Recorded Future

Note: This is just a basic overview providing quick insights into CVE-2024-24815 information. Gain full access to comprehensive CVE data, third party vulnerabilities, compromised credentials and more with Recorded Future
  • Gain complete coverage of your cyber, third party, and physical attack surface
  • Proactively mitigate threats before they turn into costly attacks
  • Make fast, effective, data-driven decisions