CVE-2024-24772

CVSS 3.1 Score 4.3 of 10 (medium)

Details

Published Feb 28, 2024
CWE ID 20

Summary

The vulnerability with the CVE ID CVE-2024-24772 affects Apache Superset versions before 3.0.4 and from 3.1.0 before 3.1.1. It allows a guest user to exploit a chart data REST API and send arbitrary SQL statements, potentially leaking information from the underlying analytics database. The risk score for this vulnerability is 5, with a base severity of MEDIUM. Users are advised to upgrade to version 3.1.1 or 3.0.4 to fix the issue. The potential danger posed by this vulnerability includes unauthorized access and potential data leakage from the analytics database if exploited by malicious actors.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-24772 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options