CVE-2024-24755

CVSS 3.1 Score 5.3 of 10 (medium)

Details

Published Feb 1, 2024
Updated: Feb 9, 2024
CWE ID 200

Summary

CVE-2024-24755 is a vulnerability that affects the discourse-group-membership-ip-block plugin used in the Discourse platform. This plugin was found to send group custom fields to the client, including fields from other plugins that may have expected their custom fields to remain confidential. The vulnerability has a base severity of MEDIUM and a base score of 5.3, indicating a moderate level of risk. It does not require any special privileges or user interaction and can be exploited over a network. The impact on confidentiality is low, with an impact score of 1.4. To remediate this vulnerability, it is recommended to update the discourse-group-membership-ip-block plugin to a patched version that addresses the issue. Organizations using this plugin should be aware of the potential exposure of sensitive information and take appropriate measures to protect their data.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-24755 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options