CVE-2024-24575

CVSS 3.1 Score 7.5 of 10 (high)

Details

Published Feb 6, 2024
Updated: Feb 22, 2024
CWE ID 400

Summary

CVE-2024-24575 is a vulnerability in libgit2, a portable C implementation of the Git core methods. It affects versions before 1.4.0 and can potentially cause a Denial of Service (DoS) attack in the calling application. The vulnerability arises from an edge-case during parsing, allowing an attacker to force loop conditions to access arbitrary memory. This could also lead to memory leakage if the extracted rev spec is reflected back to the attacker. To remediate this issue, users should upgrade to version 1.6.5 or 1.7.2. The vulnerability has a base severity rating of HIGH and an exploitability score of 3.9 according to NVD@NIST.gov, with a potential impact on availability but no impact on integrity or confidentiality.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-24575 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options