CVE-2024-24574

CVSS 3.1 Score 6.1 of 10 (medium)

Details

Published Feb 5, 2024
Updated: Feb 12, 2024
CWE ID 79
CWE ID 80

Summary

CVE-2024-24574 is a cross-site scripting (XSS) vulnerability that affects the phpMyFAQ open source FAQ web application for PHP 8.1+ and various databases. The vulnerability allows for the execution of JavaScript code on the client side through an unsafe echo of a filename in attachments.php. The issue has been fixed in version 3.2.5 of phpMyFAQ. This vulnerability poses a medium risk to organizations as it requires user interaction, but it has low impact on confidentiality and integrity, and does not affect availability. Remediation involves updating to the patched version of phpMyFAQ to mitigate the risk of exploitation.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-24574 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options