CVE-2024-2450

CVSS 3.1 Score 8.8 of 10 (high)

Details

Published Mar 15, 2024
CWE ID 287

Summary

CVE-2024-2450 is a vulnerability that affects Mattermost versions 8.1.x before 8.1.10, 9.2.x before 9.2.6, 9.3.x before 9.3.2, and 9.4.x before 9.4.3. It allows an authenticated attacker to take over other user accounts by exploiting a failure in correctly verifying account ownership when switching from email to SAML authentication under specific conditions. The base severity of this vulnerability is rated as HIGH, with a base score of 8.8 out of 10, indicating a significant potential danger to organizations using affected versions of Mattermost. To remediate this vulnerability, organizations should update their Mattermost installations to version 8.1.10, 9.2.6, 9.3.2, or 9.4.3 or newer versions that address the issue and properly verify account ownership during the authentication process.

Please note: The information provided here is based on the given data and does not contain any personal analysis or opinion about the vulnerability's severity or impact on organizations' security posture

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-2450 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options