CVE-2024-2443

CVSS 3.1 Score 9.1 of 10 (high)

Details

Published Mar 20, 2024
Updated: Mar 21, 2024
CWE ID 20

Summary

CVE-2024-2443 is a command injection vulnerability that affects all versions of GitHub Enterprise Server prior to 3.13. It was discovered that an attacker with an editor role in the Management Console could gain admin SSH access to the appliance when configuring GeoJSON settings. Exploitation of this vulnerability requires access to the GitHub Enterprise Server instance and access to the Management Console with the editor role. The vulnerability has been fixed in versions 3.8.17, 3.9.12, 3.10.9, 3.11.7, and 3.12.1 of GitHub Enterprise Server. This vulnerability poses a high risk to organizations as it allows unauthorized access and potential compromise of sensitive information stored on GitHub Enterprise Server instances.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-2443 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options