CVE-2024-24189

CVSS 3.1 Score 9.8 of 10 (high)

Details

Published Feb 7, 2024
Updated: Feb 10, 2024
CWE ID 416

Summary

CVE-2024-24189 is a use-after-free vulnerability discovered in Jsish v3.5.0 (commit 42c694c) through the SplitChar in ./src/jsiUtils.c. This vulnerability affects the lb9HtS product. The base severity of this vulnerability is rated as CRITICAL with a base score of 9.8, indicating a high potential danger to organizations. The exploitability score is 3.9, and the impact score is 5.9. It does not require any privileges or user interaction and can be exploited over the network. The integrity and confidentiality impact are both rated as HIGH, while the attack complexity is LOW, and availability impact is HIGH. To remediate this vulnerability, it is recommended to update to a version of Jsish that has fixed this issue or apply any patches provided by the vendor.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-24189 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options