CVE-2024-24004

CVSS 3.1 Score 9.8 of 10 (high)

Details

Published Feb 7, 2024
Updated: Feb 9, 2024
CWE ID 89

Summary

CVE-2024-24004 is a critical SQL Injection vulnerability affecting jshERP v3.3. The vulnerability lies in the com.jsh.erp.controller.DepotHeadController: com.jsh.erp.utils.BaseResponseInfo findInOutDetail() function, where the column and order parameters are not adequately filtered. This allows an attacker to construct a malicious payload to bypass jshERP's protection mechanism in the safeSqlParse method, resulting in successful SQL injection attacks. The vulnerability has a base severity score of 9.8 out of 10, indicating its high potential danger to organizations. To remediate this vulnerability, it is recommended to apply the latest patches or updates provided by the vendor promptly.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-24004 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options