CVE-2024-23898

CVSS 3.1 Score 8.8 of 10 (high)

Details

Published Jan 24, 2024
Updated: Feb 29, 2024
CWE ID 346

Summary

CVE-2024-23898 is a vulnerability that affects Jenkins versions 2.217 through 2.441, as well as LTS versions 2.222.1 through 2.426.2. This vulnerability allows for cross-site WebSocket hijacking (CSWSH), enabling attackers to execute CLI commands on the Jenkins controller. The affected products include a range of different versions and components within the Jenkins ecosystem. Remediation for this vulnerability involves updating Jenkins to a version beyond the affected range, specifically version 2.442 or later for the non-LTS release line and version 2.426.3 or later for the LTS release line. This vulnerability poses a high risk to organizations using Jenkins as it can be exploited remotely without any privileges required and can result in significant impacts on integrity, confidentiality, and availability of systems.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-23898 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options