CVE-2024-23877

CVSS 3.1 Score 8.2 of 10 (high)

Details

Published Jan 26, 2024
Updated: Feb 15, 2024
CWE ID 79

Summary

CVE-2024-23877 is a vulnerability in Cups Easy (Purchase & Inventory) version 1.0, which allows for a Cross-Site Scripting (XSS) attack through the currencyid parameter in /cupseasylive/currencycreate.php. This vulnerability arises due to inadequate encoding of user-controlled inputs. If exploited, a remote attacker can send a specially crafted URL to an authenticated user and potentially steal their session cookie credentials. The base severity of this vulnerability is rated as HIGH, with a base score of 8.2 out of 10. The impact primarily affects confidentiality, with low impact on integrity and no impact on availability. The vulnerability has been assigned CWE-79, which refers to the improper neutralization of input during web page generation (cross-site scripting).

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-23877 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options