CVSS 3.1 Score 6.1 of 10 (medium)


Published Jan 30, 2024
Updated: Feb 6, 2024


CVE-2024-23841 is a cross-site scripting vulnerability found in the apollo-client-nextjs package, specifically the @apollo/experimental-apollo-client-nextjs NPM package. This vulnerability requires an attacker to inject malicious input or manipulate a GraphQL server to return malicious input. To address this issue, it is recommended to update to version 0.7.0 or later. The vulnerability has a base severity of MEDIUM and a base score of 6.1 according to the National Vulnerability Database (NVD). The exploitability score is 2.8, and it requires user interaction in a network attack vector. The impact on confidentiality and integrity is low, while availability is not affected.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-23841 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options