CVE-2024-23821

CVSS 3.1 Score 4.8 of 10 (medium)

Details

Published Mar 20, 2024
Updated: Mar 21, 2024
CWE ID 79

Summary

CVE-2024-23821 is a vulnerability that affects GeoServer, an open source software server written in Java used for sharing and editing geospatial data. Versions prior to 2.23.4 and 2.24.1 are vulnerable to a stored cross-site scripting (XSS) attack, allowing an authenticated administrator with workspace-level privileges to store a JavaScript payload in the GeoServer catalog. This payload can execute in the context of another user's browser when viewed in the GWC Demos Page. While access to the GWC Demos Page is available to all users, data security measures may limit the ability to trigger the XSS. The issue has been patched in versions 2.23.4 and 2.24.1. The vulnerability has a base severity rating of MEDIUM with a CVSS score of 4.8/10 and requires high privileges and user interaction for exploitation. The impact on integrity and confidentiality is low, and there is no availability impact expected as per current analysis from security-advisories@github.com.

Note: This summary does not include information from sources other than the given text but provides an informative overview of the vulnerability based on the provided details only.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-23821 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options