CVE-2024-23819

CVSS 3.1 Score 4.8 of 10 (medium)

Details

Published Mar 20, 2024
Updated: Mar 21, 2024
CWE ID 79

Summary

CVE-2024-23819 is a cross-site scripting (XSS) vulnerability found in GeoServer, an open-source software server used for sharing and editing geospatial data. This vulnerability affects versions prior to 2.23.4 and 2.24.1 of GeoServer. An authenticated administrator with workspace-level privileges can exploit this vulnerability to store a JavaScript payload in the GeoServer catalog. When viewed in the MapML HTML Page, this payload executes in the context of another user's browser. It is important to note that the MapML extension must be installed and access to the MapML HTML Page is available to all users for this vulnerability to be triggered. However, data security measures may limit users' ability to trigger the XSS. The issue has been patched in versions 2.23.4 and 2.24.1 of GeoServer.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-23819 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options