CVSS 3.1 Score 4.8 of 10 (medium)


Published Mar 20, 2024
Updated: Mar 21, 2024


CVE-2024-23818 is a stored cross-site scripting (XSS) vulnerability that affects GeoServer, an open source software server used for sharing and editing geospatial data. The vulnerability exists in versions prior to 2.23.3 and 2.24.1, allowing an authenticated administrator with workspace-level privileges to store a JavaScript payload in the GeoServer catalog. This payload executes in the context of another user's browser when viewed in the WMS GetMap OpenLayers Output Format. While all users have access to the WMS OpenLayers Format by default, data and service security measures may limit their ability to trigger the XSS. The issue has been patched in versions 2.23.3 and 2.24.1, mitigating the vulnerability's risk of exploitation.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-23818 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options