CVE-2024-23749

CVSS 3.1 Score 7.8 of 10 (high)

Details

Published Feb 9, 2024
Updated: Feb 14, 2024
CWE ID 77

Summary

CVE-2024-23749 is a vulnerability that affects KiTTY versions 0.76.1.13 and earlier. This vulnerability allows for command injection via the filename variable, resulting from insufficient input sanitization and validation, failure to escape special characters, and insecure system calls. Attackers can exploit this vulnerability to execute arbitrary code. The affected products include various versions of KiTTY. To remediate this vulnerability, users should update to a version of KiTTY that is later than 0.76.1.13 and implement proper input sanitization and validation measures. This vulnerability poses a high risk to organizations as it can lead to arbitrary code execution, compromising the integrity and confidentiality of their systems.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-23749 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options