CVE-2024-23730

CVSS 3.1 Score 9.8 of 10 (high)

Details

Published Jan 21, 2024
Updated: Jan 29, 2024

Summary

CVE-2024-23730 is a critical vulnerability that affects LlamaHub (aka llama-hub) before version 0.0.67. The OpenAPI and ChatGPT plugin loaders in LlamaHub are vulnerable to arbitrary code execution due to the lack of using safe_load for YAML. This vulnerability has a CVSS score of 9.8, indicating its severity. It does not require any privileges or user interaction and can be exploited over a network. The impact of this vulnerability is high, with both confidentiality and integrity being compromised. To remediate this vulnerability, organizations should update their LlamaHub installations to version 0.0.67 or later to ensure safe loading of YAML files and mitigate the risk it poses to their systems and data.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-23730 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options