CVE-2024-23680

CVSS 3.1 Score 5.3 of 10 (medium)

Details

Published Jan 19, 2024
Updated: Jan 26, 2024
CWE ID 347

Summary

CVE-2024-23680 is a vulnerability in the AWS Encryption SDK for Java versions 2.0.0 to 2.2.0 and less than 1.9.0. It is categorized as CWE-347 (IMPROPER VERIFICATION OF CRYPTOGRAPHIC SIGNATURE). The vulnerability arises from the incorrect validation of some invalid ECDSA signatures. The affected products include various versions of uStpr, hEwc0h, and hEwc0g. The base severity of this vulnerability is rated as MEDIUM with a base score of 5.3 according to NVD@nist.gov. The risk score associated with this vulnerability is 25, and the exploitability score is 3.9 out of 10. It poses a potential danger to organizations as it can impact the integrity of cryptographic signatures, although the confidentiality impact is considered low. No further analysis or remediation information is provided in the source text for this vulnerability at this time

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-23680 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options