CVE-2024-23648

CVSS 3.1 Score 8.8 of 10 (high)

Details

Published Jan 24, 2024
Updated: Feb 2, 2024
CWE ID 74

Summary

CVE-2024-23648 is a vulnerability that affects Pimcore's Admin Classic Bundle, a backend user interface for Pimcore. Prior to version 1.2.3, the password reset functionality in this bundle sends an email to users containing a URL with a unique token to reset their password. However, the reset-password URL is crafted using the "Host" HTTP header of the request, which can be manipulated by an external attacker. If a user clicks on the link and the attacker controls the specified "Host" header, they can retrieve the reset token and perform an account takeover. This vulnerability has a high risk score of 65 and a base severity rating of HIGH according to security advisories. Organizations using affected versions of Pimcore's Admin Classic Bundle should update to version 1.2.3 to remediate this vulnerability and protect against potential account takeovers.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-23648 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options