CVE-2024-23641

CVSS 3.1 Score 7.5 of 10 (high)

Details

Published Jan 24, 2024
Updated: Feb 5, 2024
CWE ID 20

Summary

CVE-2024-23641 is a vulnerability affecting SvelteKit, a web development kit. Sending a GET request with a body to a built and previewed/hosted SvelteKit app in version 2 results in the app crashing and requiring manual restart. Additionally, TRACE requests also cause the app to crash. Prerendered pages and SvelteKit 1 apps are not affected. The vulnerability has been patched in versions 2.1.2, 3.0.3, and 4.0.1 of @sveltejs/adapter-node and version 2.4.3 of @sveltejs/kit. This vulnerability has a high base severity rating with a base score of 7.5, indicating a potentially significant danger to organizations using the affected products.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-23641 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options