CVE-2024-23640

CVSS 3.1 Score 4.8 of 10 (medium)

Details

Published Mar 20, 2024
CWE ID 79

Summary

CVE-2024-23640 is a stored cross-site scripting (XSS) vulnerability that affects GeoServer, an open-source software server used for sharing and editing geospatial data. The vulnerability exists in versions prior to 2.23.3 and 2.24.0, allowing an authenticated administrator with workspace-level privileges to store a JavaScript payload in uploaded style/legend resources or a specially crafted datastore file. When viewed in the Style Publisher, this payload executes in the context of another user's browser. While access to the Style Publisher is available to all users, data security measures may limit users' ability to trigger the XSS. The issue has been fixed in versions 2.23.3 and 2.24.0, and organizations using earlier versions should update to mitigate the risk of potential attacks exploiting this vulnerability. The vulnerability has a base severity of MEDIUM and requires HIGH privileges to exploit, with LOW impacts on integrity and confidentiality of data, and no impact on availability.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-23640 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options