CVE-2024-23612

CVSS 3.1 Score 7.8 of 10 (high)

Details

Published Mar 11, 2024
Updated: Mar 12, 2024
CWE ID 755

Summary

CVE-2024-23612 is an improper error handling vulnerability in LabVIEW that can lead to remote code execution. To exploit this vulnerability, an attacker needs to provide a user with a specially crafted VI. LabVIEW 2024 Q1 and earlier versions are affected by this vulnerability. The base severity of this vulnerability is rated as HIGH, with a base score of 7.8 according to the CVSS:3.1 scoring system. The impact includes high integrity and confidentiality impacts, with availability also being affected. The privileges required for exploitation are low, and there is no user interaction required. It has been classified as a secondary type of vulnerability and has an exploitability score of 1.8 out of 10. Organizations using LabVIEW should update to the latest version to remediate this vulnerability and prevent potential remote code execution attacks.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-23612 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options