CVE-2024-23451

CVSS 3.1 Score 4.4 of 10 (medium)

Details

Published Mar 27, 2024
Updated: Mar 28, 2024
CWE ID 863

Summary

CVE-2024-23451 is an Incorrect Authorization vulnerability that affects Elasticsearch versions 8.10.0 and earlier, specifically in the API key based security model for Remote Cluster Security. This issue allows a malicious user with a valid API key for a remote cluster configured to use Remote Cluster Security to read arbitrary documents from any index on the remote cluster. However, this vulnerability only occurs if the user utilizes the Elasticsearch custom transport protocol and includes the target index ID, shard ID, and document ID in their requests. It is important to note that none of Elasticsearch REST API endpoints are affected by this vulnerability. To remediate this issue, organizations using affected versions should update to Elasticsearch version 8.13.0 or later. This vulnerability poses a medium potential danger to organizations as it could lead to unauthorized access and retrieval of sensitive information from remote clusters if exploited by a malicious actor with high privileges.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-23451 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options