CVE-2024-22705

CVSS 3.1 Score 7.8 of 10 (high)

Details

Published Jan 23, 2024
Updated: Jan 29, 2024
CWE ID 125

Summary

CVE-2024-22705 is a cyber vulnerability affecting the Linux kernel before version 6.6.10. The vulnerability, classified as CWE-125 (Out-of-bounds Read), allows for an out-of-bounds access in the smb2_get_data_area_len function in fs/smb/server/smb2misc.c, due to mishandled data relationships. The affected products include Qtrc2o, ohMfk4, Qtrc2i, and several others. The vulnerability has a base severity rating of HIGH with a base score of 7.8 according to NIST. It requires low privileges and has no user interaction required. The attack vector is local, and it poses a high impact on both integrity and confidentiality. Remediation should involve updating the Linux kernel to version 6.6.10 or newer to mitigate the potential danger this vulnerability poses to organizations' systems and data.

Note: Please note that the provided information is based on the given text and may not represent the complete context or details of the actual CVE vulnerability report.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-22705 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options