CVE-2024-22207

CVSS 3.1 Score 5.3 of 10 (medium)

Details

Published Jan 15, 2024
Updated: Feb 16, 2024
CWE ID 1188

Summary

CVE-2024-22207 is a vulnerability affecting the fastify-swagger-ui plugin, specifically versions prior to 2.1.0. This vulnerability exposes all files in the module's directory via HTTP routes served by the module if the default configuration of @fastify/swagger-ui is used without setting the baseDir option. The vulnerability is fixed in version 2.1.0, and setting the baseDir option can also mitigate this issue. The potential danger posed to an organization is rated as MEDIUM, with a base score of 5.3 according to CVSS version 3.1, indicating a moderate severity level. The confidentiality impact is rated as LOW, and no privileges are required for exploitation.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-22207 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options