CVE-2024-22204

CVSS 3.1 Score 5.3 of 10 (medium)

Details

Published Jan 23, 2024
Updated: Feb 2, 2024
CWE ID 22

Summary

CVE-2024-22204 is a vulnerability that affects versions 0.8.3 and prior of the self-hosted metasearch engine, Whoogle Search. This vulnerability allows an attacker to save and overwrite files on the system with a dictionary containing arbitrary data and a limited file write. The issue arises due to insecure concatenation of user-controlled variables, leading to path manipulation. The affected products include multiple versions of Whoogle Search. To remediate this vulnerability, users are advised to update to version 0.8.4, which contains a patch for the issue. If left unaddressed, this vulnerability poses a medium risk to organizations as it can potentially lead to unauthorized access and manipulation of files on the system.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-22204 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options