CVE-2024-22142

CVSS 3.1 Score 7.1 of 10 (high)

Details

Published Jan 13, 2024
Updated: Jan 19, 2024
CWE ID 79

Summary

CVE-2024-22142 is a vulnerability categorized as CWE-79 (Improper Neutralization of Input During Web Page Generation, also known as Cross-site Scripting) affecting Cozmoslabs Profile Builder Pro versions up to 3.10.0. This vulnerability allows for Reflected XSS attacks, posing a high risk to organizations. The vulnerability has a base severity of HIGH (base score of 7.1) and requires user interaction, but does not require any privileges. The attack vector is through the network and the impact on integrity and confidentiality is low. The exploitability score is 2.8, indicating that it can be exploited relatively easily. Remediation for this vulnerability should involve updating Profile Builder Pro to a version beyond 3.10.0 to ensure the mitigation of this security flaw.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-22142 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options