CVE-2024-21885

CVSS 3.1 Score 7.8 of 10 (high)

Details

Published Feb 28, 2024
CWE ID 122

Summary

A vulnerability with the CVE ID CVE-2024-21885 has been identified in the X.Org server. This flaw exists in the XISendDeviceHierarchyEvent function, allowing for a possible heap buffer overflow condition when certain new device IDs are added to the xXIHierarchyInfo struct. This vulnerability can lead to an application crash or remote code execution in SSH X11 forwarding environments. The base severity of this vulnerability is rated as HIGH, with a CVSS score of 7.8. The privileges required to exploit this vulnerability are low, and it can be exploited locally without user interaction. The impact includes a high risk to integrity and confidentiality, as well as a high availability impact. It is recommended to apply appropriate security patches or updates provided by X.Org server to remediate this vulnerability and protect organizations from potential attacks.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-21885 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options