CVE-2024-21802

CVSS 3.1 Score 8.8 of 10 (high)

Details

Published Feb 26, 2024
CWE ID 122

Summary

CVE-2024-21802 is a heap-based buffer overflow vulnerability that affects the GGUF library in the llama.cpp Commit 18c2e17. This vulnerability can be exploited by providing a specially crafted .gguf file, which can lead to code execution. The base severity of this vulnerability is rated as HIGH, with a CVSS score of 8.8, indicating a significant potential danger to organizations. The attack vector is through the network, and user interaction is required for exploitation. The impact includes high integrity and confidentiality impacts, as well as high availability impact. To remediate this vulnerability, it is recommended to update to a patched version of the GGUF library as soon as it becomes available.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-21802 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options