CVE-2024-2172

CVSS 3.1 Score 9.8 of 10 (high)

Details

Published Mar 13, 2024

Summary

CVE-2024-2172 is a vulnerability affecting the Malware Scanner plugin and the Web Application Firewall plugin for WordPress, both developed by MiniOrange. The vulnerability exists in all versions up to, and including, 4.7.2 for Malware Scanner and 2.1.1 for Web Application Firewall. It allows unauthenticated attackers to escalate their privileges to that of an administrator due to a missing capability check on the mo_wpns_init() function. This vulnerability poses a high risk to organizations as it can lead to unauthorized access and control over the affected WordPress installations. Remediation measures should include updating the affected plugins to their latest versions as soon as possible to mitigate the risk of privilege escalation attacks.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-2172 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options