CVE-2024-21647

CVSS 3.1 Score 7.5 of 10 (high)

Details

Published Jan 8, 2024
Updated: Jan 11, 2024
CWE ID 444

Summary

CVE-2024-21647 is a vulnerability in the Puma web server for Ruby/Rack applications. Versions prior to 6.4.2 exhibited incorrect behavior when parsing chunked transfer encoding bodies, allowing for HTTP request smuggling. This vulnerability has the potential to cause unbounded resource consumption, such as CPU and network bandwidth, if exploited. The issue has been fixed in versions 6.4.2 and 5.6.8 of Puma. The vulnerability poses a high risk to organizations using affected versions of the Puma web server, and it is important for them to update to the fixed versions in order to mitigate this potential danger.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-21647 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options