CVE-2024-21643

CVSS 3.1 Score 7.1 of 10 (high)

Details

Published Jan 10, 2024
Updated: Jan 19, 2024
CWE ID 94

Summary

CVE-2024-21643 is a vulnerability that affects Microsoft.IdentityModel versions prior to 7.1.2 (for 7x) or 6.34.0 (for 6x). The vulnerability arises from the trust of the 'jku' claim by default in the SignedHttpRequest protocol, which allows for potential exploitation through remote or local HTTP GET requests. To mitigate this vulnerability, users are advised to update their Microsoft.IdentityModel versions to the recommended patches. This vulnerability is categorized as having a high base severity and poses risks to both confidentiality and integrity of affected organizations.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-21643 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options