CVE-2024-21628

CVSS 3.1 Score 5.4 of 10 (medium)

Details

Published Jan 2, 2024
Updated: Jan 8, 2024
CWE ID 79

Summary

CVE-2024-21628 is a vulnerability that affects PrestaShop, an open-source e-commerce platform. The vulnerability exists in versions prior to 8.1.3, where the isCleanHtml method is not used on a specific form, allowing for the storage of a cross-site scripting payload in the database. This vulnerability poses a low impact because HTML is not interpreted in the back office (BO) due to twig's escape mechanism. However, in the front office (FO), a cross-site scripting attack can be effective but only affects the customer sending it or the customer session from which it was sent. To remediate this issue, users are advised to update to version 8.1.3, which contains a patch for this vulnerability.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-21628 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options