CVE-2024-21519

CVSS 3.1 Score 7.2 of 10 (high)

Details

Published Jun 22, 2024
Updated: Jun 27, 2024
CWE ID 20

Summary

CVE-2024-21519 is a vulnerability that affects versions of the package opencart/opencart from 4.0.0.0. It is an Arbitrary File Creation issue that allows an attacker with admin privileges to inject PHP code into the database and create a backup file with an arbitrary filename and extension within /system/storage/backup. The created file is unlikely to be available within the web root, as recommended security measures suggest moving the storage path outside of the web root. The vulnerability has a high severity rating, with a base score of 7.2, and can have a significant impact on confidentiality and integrity.

Prevent cyber attacks with Recorded Future by prioritizing and patching critical vulnerabilities being exploited by threat actors targeting your industry. Book your demo to learn more.

Share

Prioritize, Pinpoint, and Act to Prevent Vulnerability Exploits with Recorded Future

Note: This is just a basic overview providing quick insights into CVE-2024-21519 information. Gain full access to comprehensive CVE data, third party vulnerabilities, compromised credentials and more with Recorded Future
  • Gain complete coverage of your cyber, third party, and physical attack surface
  • Proactively mitigate threats before they turn into costly attacks
  • Make fast, effective, data-driven decisions