CVE-2024-21512

CVSS 3.1 Score 8.2 of 10 (high)

Details

Published May 29, 2024
CWE ID 1321

Summary

CVE-2024-21512 is a vulnerability found in versions of the mysql2 package prior to 3.9.8. This vulnerability is categorized as Prototype Pollution and occurs due to improper sanitization of user input passed to fields and tables when using nestTables. The affected domain is BIuvGo. The base severity rating for this vulnerability is HIGH with a base score of 8.2, indicating a significant potential danger to organizations. The exploitability score is 3.9, with an impact score of 4.2, suggesting that an attacker can exploit this vulnerability remotely without any user interaction required. However, it should be noted that the privileges required for exploitation are NONE, and the confidentiality impact is rated as NONE as well. Remediation for this vulnerability involves updating the mysql2 package to version 3.9.8 or newer to mitigate the risk it poses to organizations' integrity and availability.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-21512 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options