CVE-2024-21501

CVSS 3.1 Score 5.3 of 10 (medium)

Details

Published Feb 24, 2024
Updated: Mar 6, 2024
CWE ID 200

Summary

CVE-2024-21501 is a vulnerability found in versions of the package sanitize-html prior to 2.12.1. This vulnerability exposes information when used on the backend with the style attribute allowed, enabling an attacker to enumerate files on the system, including project dependencies. The potential danger of this vulnerability lies in the attacker gathering details about the file system structure and dependencies of the targeted server. To remediate this vulnerability, users should update to version 2.12.1 or later of sanitize-html package. The severity of this vulnerability has been rated as MEDIUM with a base score of 5.3 according to CVSS v3.1, indicating a moderate level of risk.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-21501 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options