CVE-2024-21496

CVSS 3.1 Score 6.1 of 10 (medium)

Details

Published Feb 17, 2024
Updated: Feb 20, 2024
CWE ID 79

Summary

CVE-2024-21496 is a vulnerability that affects all versions of the package github.com/greenpau/caddy-security. It is a Cross-site Scripting (XSS) vulnerability that is caused by improper input sanitization of the Referer header. While some characters in the Referer header are escaped to prevent XSS attacks, it fails to account for JavaScript URL scheme attacks. This vulnerability, although not easily exploitable, could potentially allow an attacker to execute malicious scripts in the context of the target user's browser and compromise user sessions. Remediation for this vulnerability would involve updating to a version of the package that addresses this issue. The severity of this vulnerability is rated as medium with low integrity and confidentiality impact, and it requires user interaction for exploitation.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-21496 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options