CVE-2024-2141

CVSS 3.1 Score 6.4 of 10 (medium)

Details

Published Mar 30, 2024
Updated: Apr 1, 2024

Summary

CVE-2024-2141 is a vulnerability found in the Ultimate Addons for Beaver Builder – Lite plugin for WordPress. This vulnerability affects all versions up to and including 1.5.7 of the plugin. The issue arises from insufficient input sanitization and output escaping in the Button widget, which allows authenticated attackers with contributor-level access or higher to inject arbitrary web scripts into pages. These scripts can then execute whenever a user accesses an affected page. The risk score for this vulnerability is 25, with a base severity of MEDIUM. It has a low privilege requirement and does not require any user interaction. The attack vector is through the network, and the impact on integrity and confidentiality is low. Remediation for this vulnerability would involve updating the Ultimate Addons for Beaver Builder – Lite plugin to a version beyond 1.5.7 or applying any available patches/fixes provided by the plugin developer.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-2141 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options