CVSS 3.1 Score 6.4 of 10 (medium)


Published Mar 30, 2024
Updated: Apr 1, 2024


CVE-2024-2141 is a vulnerability found in the Ultimate Addons for Beaver Builder – Lite plugin for WordPress. This vulnerability affects all versions up to and including 1.5.7 of the plugin. The issue arises from insufficient input sanitization and output escaping in the Button widget, which allows authenticated attackers with contributor-level access or higher to inject arbitrary web scripts into pages. These scripts can then execute whenever a user accesses an affected page. The risk score for this vulnerability is 25, with a base severity of MEDIUM. It has a low privilege requirement and does not require any user interaction. The attack vector is through the network, and the impact on integrity and confidentiality is low. Remediation for this vulnerability would involve updating the Ultimate Addons for Beaver Builder – Lite plugin to a version beyond 1.5.7 or applying any available patches/fixes provided by the plugin developer.

Prevent cyber attacks with Recorded Future by prioritizing and patching critical vulnerabilities being exploited by threat actors targeting your industry. Book your demo to learn more.


Prioritize, Pinpoint, and Act to Prevent Vulnerability Exploits with Recorded Future

Note: This is just a basic overview providing quick insights into CVE-2024-2141 information. Gain full access to comprehensive CVE data, third party vulnerabilities, compromised credentials and more with Recorded Future
  • Gain complete coverage of your cyber, third party, and physical attack surface
  • Proactively mitigate threats before they turn into costly attacks
  • Make fast, effective, data-driven decisions