CVE-2024-2030

CVSS 3.1 Score 6.4 of 10 (medium)

Details

Published Mar 13, 2024

Summary

CVE-2024-2030 is a vulnerability affecting the Database for Contact Form 7, WPforms, and Elementor forms plugin for WordPress. This vulnerability allows authenticated attackers with contributor-level permissions or above to inject arbitrary web scripts in pages, leading to stored cross-site scripting attacks. The issue arises due to insufficient input sanitization and output escaping on user-supplied attributes within the plugin's shortcode(s). All versions up to and including 1.3.3 of the affected plugins are vulnerable. Organizations can remediate this vulnerability by updating to a version of the plugins that addresses the issue. The potential danger posed by this vulnerability is considered medium, with a base severity score of 6.4 out of 10.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-2030 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options