CVE-2024-1952

CVSS 3.1 Score 3.1 of 10 (low)

Details

Published Feb 29, 2024
CWE ID 200

Summary

CVE-2024-1952 is a vulnerability that affects Mattermost version 8.1.x before 8.1.9. It allows an authenticated attacker who can control the update of an ephemeral post to access the contents of individual posts in channels they are not a member of. The vulnerability arises from the failure to properly sanitize data associated with permalinks when a plugin updates an ephemeral post. To remediate this vulnerability, it is recommended to upgrade Mattermost to version 8.1.9 or later. This vulnerability poses a potential danger to organizations as it could lead to unauthorized access and exposure of sensitive information in channels that should be restricted to certain members only.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-1952 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options