CVE-2024-1806

CVSS 3.1 Score 6.4 of 10 (medium)

Details

Published Mar 13, 2024

Summary

CVE-2024-1806 is a vulnerability found in the Paid Membership Plugin, Ecommerce, User Registration Form, Login Form, User Profile & Restrict Content – ProfilePress plugin for WordPress. This vulnerability allows authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages using the plugin's shortcode(s). The vulnerability exists in all versions up to and including 4.15.1 due to insufficient input sanitization and output escaping on user supplied attributes. The potential danger of this vulnerability is that it enables the execution of arbitrary scripts whenever a user accesses an injected page. It is recommended to update the affected plugin to a secure version as a remediation measure.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-1806 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options