CVE-2024-1691

CVSS 3.1 Score 6.1 of 10 (medium)

Details

Published Mar 13, 2024

Summary

CVE-2024-1691 is a vulnerability found in the Otter Blocks – Gutenberg Blocks, Page Builder for Gutenberg Editor & FSE PRO plugin for WordPress. This vulnerability, present in versions up to and including 2.6.3, allows for Stored Cross-Site Scripting via file upload form, specifically allowing SVG uploads. Insufficient input sanitization and output escaping make it possible for unauthenticated attackers to inject arbitrary web scripts into pages that will execute whenever a user accesses an injected page. Although the patch in version 2.6.4 allows SVG uploads, the uploaded SVG files are sanitized to mitigate the risk. The base severity of this vulnerability is medium with a score of 6.1 and a risk score of 25, indicating its potential danger to organizations using the affected plugin.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-1691 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options