CVE-2024-1597

CVSS 3.1 Score 10.0 of 10 (high)

Details

Published Feb 19, 2024
Updated: Mar 25, 2024
CWE ID 89

Summary

CVE-2024-1597 is a vulnerability in pgjdbc, the PostgreSQL JDBC Driver, that allows attackers to inject SQL if using PreferQueryMode=SIMPLE. This vulnerability affects versions before 42.7.2, 42.6.1, 42.5.5, 42.4.4, 42.3.9, and 42.2.8 of the driver. To remediate this issue, users should update to the latest version of pgjdbc (v42.7.2 or later). The potential danger posed by this vulnerability is that an attacker can exploit it to alter queries and bypass the protections provided by parameterized queries against SQL Injection attacks.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-1597 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options