CVE-2024-1590

CVSS 3.1 Score 4.6 of 10 (medium)

Details

Published Feb 23, 2024

Summary

CVE-2024-1590 is a vulnerability affecting the Page Builder: Pagelayer - Drag and Drop website builder plugin for WordPress. This vulnerability allows authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages, leading to stored cross-site scripting. The vulnerability exists in all versions up to and including 1.8.2 of the plugin due to insufficient input sanitization and output escaping on user-supplied attributes. To remediate this vulnerability, users should update their plugin to the latest version available. The potential danger this vulnerability poses to organizations is a medium level of risk, with low privileges required for exploitation and user interaction being necessary for successful attacks. The impact includes low integrity and confidentiality impacts, while the availability impact is none.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-1590 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options