CVE-2024-1528

CVSS 3.1 Score 7.4 of 10 (high)

Details

Published Mar 12, 2024
CWE ID 79

Summary

CVE-2024-1528 is a Cross-Site Scripting (XSS) vulnerability found in CMS Made Simple version 2.2.14. The vulnerability occurs due to insufficient encoding of user-controlled input in multiple parameters, specifically through /admin/moduleinterface.php. This issue could allow a remote attacker to send a specially crafted JavaScript payload to an authenticated user, potentially leading to partial hijacking of their browser session. The affected product is CMS Made Simple version 2.2.14, and the recommended remediation is to update to a patched version provided by the vendor. The potential danger of this vulnerability lies in the attacker's ability to execute malicious code within the context of the affected user's browser session, posing a risk to confidentiality and potentially compromising sensitive information.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-1528 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options