CVE-2024-1512

CVSS 3.1 Score 9.8 of 10 (high)

Details

Published Feb 17, 2024
Updated: Feb 20, 2024

Summary

CVE-2024-1512 is a vulnerability found in the MasterStudy LMS WordPress Plugin for Online Courses and Education, affecting all versions up to and including 3.2.5. The vulnerability allows unauthenticated attackers to perform union-based SQL Injection via the 'user' parameter of the /lms/stm-lms/order/items REST route. This is due to insufficient escaping on the user-supplied parameter and lack of sufficient preparation on the existing SQL query. Exploiting this vulnerability could lead to the extraction of sensitive information from the database. The base severity of this vulnerability is classified as CRITICAL, with a base score of 9.8 out of 10, indicating a high level of risk. It has an availability impact and confidentiality impact rated as HIGH, making it crucial for organizations using this plugin to remediate it promptly to prevent potential data breaches and unauthorized access to sensitive information.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-1512 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options