CVE-2024-1482

CVSS 3.1 Score 7.1 of 10 (high)

Details

Published Feb 14, 2024
Updated: Feb 15, 2024
CWE ID 863

Summary

CVE-2024-1482 is an incorrect authorization vulnerability that was found in GitHub Enterprise Server. This vulnerability allowed an attacker with access to the Enterprise Server to create new branches in public repositories and execute arbitrary GitHub Actions workflows using the permissions from the GITHUB_TOKEN. The affected versions of GitHub Enterprise Server were after 3.8 and before 3.12, but it was fixed in versions 3.9.10, 3.10.7, and 3.11.5. The potential danger of this vulnerability lies in the unauthorized creation of branches and execution of workflows, which could lead to unauthorized access or manipulation of data within an organization's GitHub repositories.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-1482 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options